0 votes
asked in Sonstiges by (160 points)
edited by

Hallo vor mir steht ein Apple MBP M1.

Ich hab die allerletzte Version installiert ( im documents folder ), sowie 2 Versionen vom Tomcat dazuinstalliert ( 9 und 10).

Dann erstelle ich ein Projekt aus den AppLayout Template,.

Server = tomcat 9, : error 

--

LF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

Juni 09, 2021 10:02:06 AM org.apache.catalina.core.ContainerBase startInternal

SEVERE: A child container failed during start

java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/RxG4Re]]

at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)

at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)

at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:916)

--

Server = tomcat 10: started ohne Fehler aber error 404.

JRE : Workbench default 

Auf dem JCon Video sieht das alles so toll aus,, Mach ich was grundlegendes falsch ?

Grundsätzliche Frage zu Tomcat, selber installieren , oder über Servers gehen ? 

Im Workspace Ordner, hat mit Eclipse Tomcat 9 und 10 installiert. Oder doch lieber selber von der Webseite laden und in einen Ordner schieben.

Gruß und Danke

Rainer

2 Answers

0 votes
answered by (2.8k points)
Hallo Rainer,

ich habe auf einem Win 7 Rechner ähnliche Probleme gehabt. Diese Fehler treten auf, wenn in den Projekt Eigenschaften (Alt+Enter) andere Vorgaben als in der pom.xml konfiguriert sind. In beiden Einstellungen sollte seit RC 10.3 mindestens Java 11 eingestellt sein. Tomcat 9 läuft bei mir besser als Tomcat 10. Schau auch in die Facet Einstellungen. Zum Start rufe ich eine ui.xml Datei in den Editor und Starte über das QuickLaunch Dialog Fenster die Anwendung. Vielleicht hilft es ja weiter.

Gruß Frank
commented by (160 points)
Hallo Frank, Danke !!
Dachte, installieren und dann default template starten reicht, aber wie man sieht.
Dann geht meine Reise mit Java ja doch wieder weiter…
Rainer
0 votes
answered by (160 points)
edited by
Hab für mich die Lösung gefunden ( nachdem ich mir nochmals die Videos der JConn angeschaut hab).
App läuft auf Tomcat wenn:

ich sie mit Run / Debug on Server starte

Bei QuickLaunch->Start Servlet bekomme ich Error 404,

Rainer
Welcome to Rapidclipse Q&A, where you can ask questions and receive answers from other members of the community.
Powered by Question2Answer
...